May 2021 Release
Scheduled for May 11, 08:00 - 12:00 CDT
Scheduled
May Major Release — Core Platform Enhancements

We are planning to deploy our next major release to all users on May 11th, 2021. Our UAT testing environment will see changes in advance on April 12th, 2021. The release will include the following updates:

## What's new?
- Added the ability to organize Workflows into Workspaces
- Added columns endpoint to determine headers from CSV and Excel files
- Added Instance fields modal route
- Added instances grid view
- Added actions to configure data table and data table column user access in platform UI
- Added the ability to pin important fields
- Added a Milestones section to the Instance screen

## What's been improved?
- Added the ability to associate an imported Workflow with a given workspace
- Added a new version of the Workflow: End this Workflow action to support optionally cancelling all active sub-Workflows when ending a parent Workflow
- Updated the workspace endpoints to return information about the number of Workflows associated with each workspace
- Increase timeout for table filtering actions
- Added Table fields to Merge Tables action configuration
- Ensured inline helper Workflows are organized in the same workspace as the Workflow they belong to
- Updated a few pieces of the workspace UI based on design feedback
- Improved the workspace screens to reflect updates as Workflows are moved around
- Updated markdown parser to allow safe HTML
- Updated menu component styles
- Improved platform performance under sudden load
- Improved platform reliability when clients export many tables from table pages
- Adding sorting by favorites for workflows
- Improved usability around workspace navigation and management
- Added additional optional configuration options to the webform trigger
- Improved behavior on the Workspaces list screen
- Add table field validation

## What's been fixed?
- Added support for deleted users in the users application table
- Ensure that unused fields are removed when deleting a step
- Improve reliability of scheduled triggers and delayed tasks
- Fixed issue delaying deletion of instances if workflow owner was deactivated
- Added full support for defining output fields for Custom Actions
- Added view param to public readable fields
- Miscellaneous fixes to data table export API
- Resolve issues when custom actions include null values in a choice field thats not required
- Upgraded several Apollo and GraphQL packages which may resolve an issue submitting a webform
- Removed trigger element for disabled and readOnly token picker inputs
- Fixed issue preventing display of copied table from mirroring the source table
Posted Apr 08, 2021 - 15:04 CDT
This scheduled maintenance affects: Catalytic Application and Workflow Actions.